本文将介绍如何处理云服务器公网 IP 网络延迟大的情况。

问题现象

通过云服务器公网 IP 访问云服务器对外提供的 Web 服务,网络延迟增大,出现相应慢、卡顿的问题。

原因分析

当出现通过云服务器访问互联网或者互联网访问云服务响应慢时,通常有如下原因:

  • 正在上传文件到云服务器或者在云服务器从互联网下载数据。

  • 云服务器对外提供的业务,有大量流量进出(既有用户在访问您的业务)。

解决办法

  1. 通过执行 ping <公网IP> 测试公网 IP 的延迟。

    # ping 139.198.188.188 -t
    正在 Ping 139.198.188.187 具有 32 字节的数据:
    来自 139.198.188.187 的回复: 字节=32 时间=163ms TTL=52
    来自 139.198.188.187 的回复: 字节=32 时间=145ms TTL=52
    来自 139.198.188.187 的回复: 字节=32 时间=145ms TTL=52
    来自 139.198.188.187 的回复: 字节=32 时间=138ms TTL=52
    来自 139.198.188.187 的回复: 字节=32 时间=154ms TTL=52
    来自 139.198.188.187 的回复: 字节=32 时间=143ms TTL=52
    来自 139.198.188.187 的回复: 字节=32 时间=139ms TTL=52
    来自 139.198.188.187 的回复: 字节=32 时间=139ms TTL=52
    
    139.198.188.188 的 Ping 统计信息:
        数据包: 已发送 = 8,已接收 = 8,丢失 = 0 (0% 丢失),
    往返行程的估计时间(以毫秒为单位):
        最短 = 138ms,最长 =163ms,平均 = 145ms

    保持一段时间的输出内容后进行查看,只要`时间`这一列不超过 100ms,且没有太大的波动,位置在某个范围内,则说明客户端到云平台公网 IP 的网络环境比较稳定;如果超过 100ms,则表示网络有较大延迟。

  2. 确认公网 IP 的带宽上限。

    用户申请公网 IP 都是有带宽上限的,我们可以在 Console 界面查看公网 IP 的带宽上限。

    high_ping

    如上图,该公网 IP 的带宽上限为 10Mbps。

  3. 查看公网 IP 的带宽监控数据。

    high_ping

    如果有较高的进带宽,已经将 10Mbps 的带宽都占满,此时为了快速恢复 Web 服务器的正常访问,需要提高公网 IP 的带宽上限,来尽快完成数据的传输,等数据传输完毕,再将带宽调成原来的 10Mbps 即可。

    high_ping
  4. 如果没有下载或者上传,但是也出现了较高的带宽占用,则很有可能是有大量的业务访问。此时需要排查下业务层日志,看是否为正常的业务流量。

    如果是恶意攻击,可以在云服务器绑定的安全组对应端口添加一个优先级较高的拒绝规则,源 IP 填写日志中恶意访问业务的客户端 IP,然后重启业务服务来断开之前已经建立的连接。